Author Topic: Pine64 Black screen after running resize  (Read 38828 times)

Stabby

  • Jr. Member
  • **
  • Posts: 7
  • Trust: 0
    • View Profile
Pine64 Black screen after running resize
« on: May 07, 2017, 04:31:47 PM »
Hi,

I'm trying to get my Rokos rockin', and here is my tale of black screen woe:

1) I flashed my ssd card and put it in my Pine64.
2) Keyboard/mouse and monitor and ethernet and external hard drive are attached.
3) Power up the Pine64.
4) Boots beautiful.
5) I sudo run the resize-sdcard.sh in the ok-scripts folder.
6) The resize works, but says something about "the kernal has the old tables, new will be used on next reboot."
7) So, I sudo reboot.
8) Pine64 screen goes black, I hear the hd, I see the ethernet light flash, but then...
9) Nothing ever happens. The screen stays black and goes into power-saving mode.

Hmm.

10) I power off the Pine64.
11) I power up the Pine64.
12 Then same as 8 and 9 above. Nothing ever happens.

Any ideas?

I should add that this is the 2nd time. I had it running earlier today and was checking it out to see if it's a good Debian. I installed Busybox and NoMachine on it without problems. However, on subsequent boots I got the black screen thing. I was still able to NoMachine in, but the real monitor never lit up again.

I wasn't all THAT concerned, because I intend to run it headless once it is set up.  So I carried on but ran into trouble starting the Bitcoin. Finally I said screw it, re-flashed the SSD and started again, this time going straight to the resize script first thing, in case it was something in NoMachine or Busybox that was the culprit. When the black screen occurred I couldn't NoMachine it because that was not installed, and I also could not SSH in.

So, with no monitor at all it's effectively dead.

TIA.

Stabby

  • Jr. Member
  • **
  • Posts: 7
  • Trust: 0
    • View Profile
Re: Pine64 Black screen after running resize
« Reply #1 on: May 09, 2017, 08:37:40 PM »
So apparently I'm the only one that's seen this behaviour.

I have laboured mightily but tl;dr is I have the Rokos running and the hd mounted. In the course of getting the timezone setting to stick, I noticed that if I log out from Pi, there's no way to log back in. So I ssh'ed in with user Pi, and executed reboot from there.

This reproduced exactly the black screen effect, and it will never boot... with the HD attached. And no ssh because it doesn't get far enough. Booting seems to be waiting for something from the HD that it never gets.

The solution is to reboot with the HD unplugged. Then plug the HD back in, mount it and reboot, and then it comes up with no issues.

That's as far as I got today.

Stabby

  • Jr. Member
  • **
  • Posts: 7
  • Trust: 0
    • View Profile
Re: Pine64 Black screen after running resize
« Reply #2 on: May 10, 2017, 09:17:23 AM »
OK, I clicked the Bitcoin icon and the client launched and asked where I wanted to store the chain.

I picked the partition on the HD I wised to use. The dialog said "Add a / and name if you wish to create another directory". Which I did ( /bitchain ) but it complained it could not create it.

So I cancelled and tried again, intending to not append a new directory in the partition.

The result is what you see in the attached image. Hmm. I don't see how to attach the image. It shows Bitcoin client and an error message

Cannot obtain a lock on data directory /media/pi/3b9be3b8-01f1-4d9a-b6a2-669c1e6d0d37. Bitcoin Core is probably already running. No such file or directory.

Apparently Bitcoin started on my first attempt even though I cancelled. However, I see no new files in the directory, just the "here" file I created earlier just to be sure the partition was writeable.

Top shows qbitcoin is running, so my confusion is... where is it putting the blockchain?

TIA


Stabby

  • Jr. Member
  • **
  • Posts: 7
  • Trust: 0
    • View Profile
Re: Pine64 Black screen after running resize
« Reply #3 on: May 10, 2017, 12:25:52 PM »
My mistake. Bitcoin is NOT running. It only appeared in the top list because the error dialog was still open. As soon as I closed that, it quit and is not running now.

When I attempt to start it, I get the same error message:

Cannot obtain a lock on data directory /media/pi/3b9be3b8-01f1-4d9a-b6a2-669c1e6d0d37. Bitcoin Core is probably already running. No such file or directory.

lsblk looks like this:

NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda           8:0    0   1.4T  0 disk
├─sda1        8:1    0 644.5G  0 part /media/pi/wink
└─sda2        8:2    0   694G  0 part /media/pi/3b9be3b8-01f1-4d9a-b6a2-669c1e6d0d37
mmcblk0     179:0    0  29.8G  0 disk
├─mmcblk0p1 179:1    0    50M  0 part /boot
└─mmcblk0p2 179:2    0  29.8G  0 part /


It is sda2 that I wish to use for the blockchain.

How do I reset the Bitcoin client and assign it to use sda2?

TIA

Stabby

  • Jr. Member
  • **
  • Posts: 7
  • Trust: 0
    • View Profile
Re: Pine64 Black screen after running resize
« Reply #4 on: May 10, 2017, 02:33:38 PM »
Well, it's running. Not sure what I did that helped. I chmod the /media/pi 775 that might have been it.

Anyway it's running. Sync is 4 years, six months behind.

It said 21 hrs left to sync awhile ago. Now it says 43 hrs and climbing as I watch-- holy crap, in the time it took to type the above, it jumped to 3 days.

No idea if this is normal.

Now it says 4 days :(

...now 5 days... depressing, really.

OKtoshi

  • Full Member
  • ***
  • Posts: 137
  • Trust: 7
    • View Profile
Re: Pine64 Black screen after running resize
« Reply #5 on: May 10, 2017, 05:20:41 PM »


Glad to hear you fixed your issues,

About the screen issue, it seems to be a direct bug from pine64 board, it looks it skips some of the starting settings while restarted,
as it seems it hangs trying to detect the monitor.

The way I've done to prevent that behavior is that instead of doing restarts (reboot)
I just shut it down fully and then just start it up again (not experiencing that bug this way)

About Bitcoin : ) Yes, it takes a lot to sync from zero, don't listen to that estimated feedback :D It takes around 2-3 weeks afaik

Later on, we will purge a Btc chain on the pine for testing and upload so in the future the users could download a purged snapshot if all goes well.

Thanks a lot for your feedback, all these records help us improve and other users to solve their issues, appreciated!
OK is open-source; its design is public, nobody owns or controls OK and everyone can take part.

OKtoshi

  • Full Member
  • ***
  • Posts: 137
  • Trust: 7
    • View Profile
Re: Pine64 Black screen after running resize
« Reply #6 on: May 10, 2017, 05:22:11 PM »
also, for future reference, you can delete the bitcoin set data folder from the configurations by:

go to pi folder
show all hidden files
go into .config folder
delete bitcoin file (configuration file that stores the settings like the used folder for data)

then just open Bitcoin again and it will ask again where you want to save is data directory ;)

kind regards.
OK is open-source; its design is public, nobody owns or controls OK and everyone can take part.

Stabby

  • Jr. Member
  • **
  • Posts: 7
  • Trust: 0
    • View Profile
Re: Pine64 Black screen after running resize
« Reply #7 on: May 10, 2017, 07:44:33 PM »
Ah, all good to know, thanks!

The monitor bug was driving me mental. I've been building a Ubuntu server at the same time as this, and I started the Pine project for fun... this won't take long...and suddenly my mojo was not working in Pineland, leading to a long experience (with a sidetrack failing to move the rfs to the HD, but that's another story). Anyway by lunchtime today I was THIS close to tossing it out a window...

... but ROKOS is SUCH a nice experience on this 1GB Pine64 I gave it one more go. :D

So thanks for the fine work on this, and all the other delicious flavors. I have a friend with a Pine, and I'm going to set one up on hers too.

That syncing feeling: weeks, eh? Well, I'll shut down the Bitcoin and finish setting up everything else and then move it another room so the HDD can buzz madly away for weeks somewhere that's not my desk. I have it plugged monitor with a keyboard for setup, but I've had NoMachine on it to test from the start and it works great which surprised me on a 1G machine, so I can keep all the GUI goodness.

Cheers.

Stabby

  • Jr. Member
  • **
  • Posts: 7
  • Trust: 0
    • View Profile
Re: Pine64 Black screen after running resize
« Reply #8 on: May 11, 2017, 11:32:50 AM »
Honeymoon over.

1) I shut the Pine64 down last night because I need to install ssh keys so I can move it to the server room (spare bedroom) and run it headless.

2) When I restarted the Pine64 this morning, the Bitcoin client came up automatically, but  it came up with the First Run screen again. No way around it, so I clicked the button to select a location, clicked what looked like 30-odd hex character of the partition I used yesterday... and it started a new blockchain etc. right beside the one I had yesterday.

3) So I stopped that, and shut down.

4) I cold-booted the Pine64 and hit the monitor bug again (boot hangs).

5) Applied the remedial measure of turning it off, removing the external USB drive and restarting.

6) It boots without the HDD.

7) I plug in the HHD and shut down.

8 ) I cold reboot the Pine64 with the HDD attached and all is well, i.e. it boots. Does not automatically start the Bitcoin client.

And that's where it stands.

Appreciate any thoughts on the matter.